cannot import .xn file

When I try to import, an explorer window opens so I can browse to the file.  When I click on the folder, I get challenged (before I can select the actual file) for entering password for EXPORTED file.  I enter the p/w anyway, and it just goes back to the options page.

 

xnotifier 3.3.5

CFBancroft's picture

Please look at

http://xnotifier.tobwithu.com/dp/node/419

To make sure you did it right.

Thanks, CFBancroft

 

fpbiz21's picture

Hi,

I have FF 30, X-Notifier 3.4.3

And yes :-)... I read trhead: http://xnotifier.tobwithu.com/dp/node/419 and I follow step by step... after that....nothing.

Before today... it was working very well.

I hope you can help me.

Thx

CFBancroft's picture

You did export [Today's date]Firefox.xn (done?)

 

You import into which one? (Thunderbird?, SeaMonkey?, Chrome?, Safari?, and/or Opera?)

 

after that .... nothing. (Can you explain more?)

 

Thanks, CFBancroft

 

fpbiz21's picture

 Opppss...just to reply correctly...

Hi CFBancroft.

Yes, today I exported from FF.

I tried import into FF...doesn't work.

...

I have some old backups saved (exported from FF), they were imported into Thunderbird and worked.

 

I don't use SeaMonkey?, Safari...

Chrome and Opera... I didn't want risk the settings :-)

"after that .... nothing. (Can you explain more?)"

I mean, read all the steps in "http://xnotifier.tobwithu.com/dp/node/419" and followed as stated.

Thx in advance.

Richard

RpD's picture

Well... I rename my export as I'm saving it... (change the Save As... filename); I don't rename after I've saved download.txt.  Although both ways should work just fine.

I have tested both Chrome and Firefox Import, and they work fine for me.

IF you really click the IMport button... you should be able to browse, into folders, and select a file... without being prompted for (an export) password before selecting folder or file.  It should prompt for an import password -after- you select your file and click the 'Open' button.
IF it's not doing it that way (especially if it asks for an EXport password)... then I would suggest you have a corrupted installation or something else interfering with the import process.  

As for firefox... sometimes when I am attempting to IMport a known good backup file, I first will delete all the existing accounts and then click the OK, or Save button... so that I start fresh, with a blank account list.  Then I open Options back up, click IMport and find/select the export file (click OK or Open button)... which should then prompt for the import password.  So... starting fresh, when you get a successful import... you will see all your accounts listed again, instead of a blank list.  THEN you have to click OK or Save to actually save those imported account definitions, so that X-Notifier then can start checking the accounts.   If  you don't clear the accounts before IMport, you may not see a difference in the list after import... since most of the accounts will still be there.  There is no "Import complete" message... so clearing out the old, first... helps you to see a change upon completion of successful import... since it won't be blank list anymore.

fpbiz21's picture

Hi RpD...

- Yes I rename the files before be saved too, as x, y or z *.xn

- I had tested FF and Chrome before (2 weeks or a month aprox.) and also worked fine too...

- I click the import button as stated: "http://xnotifier.tobwithu.com/dp/node/419" (Please read http://xnotifier.tobwithu.com/dp/comment/7219#comment-7219)

- I don't have accounts in the XN 3.4.3 (only in backups) of the fresh installation of FF 30...

Thx in advance.

Richard

CFBancroft's picture

When you IMport into Firefox,  there already listing there (Write Over)?
or you did create NEW profile (X-N Blank Listing) before IMport?

++++++++++++++++++++

I have some old backups saved (exported from FF), they were imported into Thunderbird and worked.

'Old Backups' that is/was version 3.4.2 and before?

'Thunderbird and worked' still version 3.4.2? (TB did not yet update to 3.4.3, while Firefox updatded 3.4.3?)

++++++++++++++++++++

Thanks, CFBancroft

 

CFBancroft's picture

- I don't have accounts in the XN 3.4.3 (only in backups [that mean 3.4.2?]) of the fresh installation of FF 30...

FYI: FF website still version 3.4.2... (not release yet 3.4.3) (as of Today July 11, 2014)

you can look at
https://addons.mozilla.org/en-US/firefox/addon/xnotifier/

+++++++++++++++++++++++++++

I Guess/Solution:

1) Fresh Install FF 30 with XN 3.4.3? (If yes)
2) Please install XN 3.4.2 again... (do not update to 3.4.3 yet.)
3) IMport your old Back-up in 3.4.2 into FF 30 with 3.4.2
4 Then update to XN 3.4.3 with FF 30
5 EXport again for your future back up

+++++++++++++++++++++++++++

If you look xnotifier.xn file look for "enabled"

3.4.2 and before, that is "BC" (False or True)
3.4.3 and future is "AD" (0 or 2)
[ 1  not yet, after Tobwithu's says in public release, I will explain new features]

Thanks for understanding, CFBancroft