Problem with Hotmail

Windows 10 Pro 64bit 2004 19041.450

Waterfox Current 2020.07.2.1 g4bit

X-notifier 4.2.19

MS Edge Chromium 84.0.522.61 (64bit)

X-notifier 4.2.19.1

For the past 3(ish) days my Hotmail/Outlook accounts have been greyed out and the active account in red and icons are missing on both browsers. I have tried logging out and logging back in manually, clearing cookies, even went so far as to disable all other extensions.

WF https://i.imgur.com/eRi0Fe3.png Edge https://i.imgur.com/K7gfcPA.png (account names cropped out)

As an aside I posted in Script Requests a couple of months aga if somebody could update the Hushmail script and wondering if snybody could give that a look.

Same with me X-notifier  4.2.19.1   not working on Microsoft Edge Chrome and Mozilla Firefox  

It is all in red and I keep clearing it to try to get to work 

icegenie's picture

Same problem

Same issue here with Firefox 79.0 64 bit, Win 10 2004, X-Notifier 4.2.19.

Yes this started to happen with me as well recently.

tweek84's picture

Same to me, all my accounts are grey, no checking.

virtuado's picture

With me it's not working flawless anymore as well. 

The normal icons aren't showing, but once i click on an account i want to access, it opens like it should. 
And in general after some time, i guess a few mail check cycles, the normal icons appear.

When I preserve cookies, it works fine again and unlike gmail I can log out and it still works.

This has been an off and on situation going on with X-Notifier,  wish it would get fixed 

Still not working for Microsoft Edge Chromium and not working for Mozilla Firefox 

Never mind, not working now.

ada's picture

Config: Windows 10 family 2019 (up to date) + Firefox 79.0 (64 bits).
> Regarding FF specifically:

Same here for the past few days (it began 3 or 4 days ago).
BUT it seems that things are gradually getting back on track.
I've got 2 Hotmails and 2 Outlooks [Yahoo is working fine].
All my Outlook/Hotmails accounts went gradually down (from grey to red),
and since yesterday, all my Outlook/Hotmails accounts are gradually getting back (3/4 by now).

It seems that Microsoft/Hotmail/Outlook is making adjustements, so... wait and see?

Kind regards from Paris.

ada's picture

Well, i'm experiencing troubles too. (Same config as noted above, and with Firefox.)
> It's alright if each Hotmail/Outlook has got, at least, one unread message,
> and i've to load each account, one by one, keeping the page open (one by one) until X-notifier "detects" the unread message.s. Once the detection is done, same process with the next account.
> And then, once all the re-connections (recognitions) are made, it seems to be fine.
Otherwise, connections seem to be lost.

Je ne sais pas.

ada's picture

I want to believe!
But nope. All connections lost here too.

ada's picture

Everything is ok.

:)

 

tobwithu's picture

I saw 'We're updating our terms' page during manual login.

After I click 'Next' button in this page, X-notifier works again.

went through and 3 out of 4 accounts had that but still all greyed out and active account is in red this is even after a couple of hours and a couple of browser restarts on WF. Edge didn't show the "we're updating terms" probably because I did that on WF then went to Edge.

CFBancroft's picture

Dear Tobwithu

I am truly sorry that all websites give you a hard time every time they change their homepage that causes you to create new scripts!

Sometimes work great and sometimes not!

A little bit off the topic, more companies use "ARM architecture." product lines, including iPhone, iPad, iPod, Apple Watch, and MAC shortly, and I am sure other companies will follow.

Can you create a BRAND NEW app and only check new email via IMAP and required two-step authentication, if there is any new email just click on the "Link," i.e., — file:///Applications/Mail.app/Contents/MacOS/Mail. (for example)

So that way, you do not need to update scripts whenever their website changes.

FREE comes with one host each, i.e., Hotmail, AOL, Yahoo, Gmail, etc. at no charge if they want second or more Hotmail, AOL, Yahoo, Gmail, etc. They pay in-app cost $1.00 (one dollar) every month subscription.

The product name shall be "ARM IMAP Notifier."

What do you think?

Thanks for reading,
CFBancroft

@tobwithu
I have four Microsoft-based accounts, and if I keep fussing with them... getting them to "stay signed in", by continuing to answer the pop-up to login each account... it will not be 'persistent' the next time I start the browser.  Something is not being retained to the satisfaction of the Microsoft server apparently.  If I had just one account, perhaps this would not be a problem... but when I manage to get all four working by choosing "stay signed in", when I restart the browser, none will work to check the new email count.  This is true for Chrome, the new Edge, Edge-beta, and Firefox.

 

Hotmail accounts (1o)  all not working (the accounts-logins are always a little bit confused, but after Hotmail changed some
legal stuff some days ago, nothing works properly). Big probs to login....
Also X-notifier not displaying any 'new mail' notices.

I hope Hotmail does not change their legal stuff every 2 days again, so it won't take 6 months to fix X-notifier again....

Thanks !

tweek84's picture

I got this issue when I used "Check Now" (Sorry it's in French).

<a href="https://imgbb.com/"><img src="https://i.ibb.co/GMNR17q/Image-3.png" alt="Image-3" border="0"></a>

And all my mailboxes still unchecked and grey

tobwithu's picture

Outlook.com login process has changed.

I could not find a way to automate it.

tobwithu's picture

Outlook.com login process has changed.

I could not find a way to automate it.

icegenie's picture

When I click on my greyed out accounts, I can stil access the inboxes so I doubt the entire login process isn't working. It seems to only be the number of new emails checking feature that is broken.

I think the login process is actually working but is happening too quickly for multiple accounts.  I suspect hotmail/outlook flags it as suspecious due to all the different logins from the same session in a short amount of time.  If I have only one hotmail account enabled in X-notifier everyting works fine.  If I have multiple accounts none of them seem to work consistently.  Sometimes one or two will eventualy update.  Perhaps adding a delay of 10-15 seconds between checcking each account could resolve the issue.

I was having the same issue with hotmail, but was also having issues with gmail and other ones.  I'm not sure if this fixed it (not sure why it would fix the non-hotmail ones), but after I made this change they all started working again.

Originally I had my two hotmail accounts being checked every 6 minutes, I changed one to be 7 minutes (leaving the other at 6 minutes) and now everything seems to work fine.  This causes the checking of the two accounts to be staggard, and they will only check at the same time once every 42 minutes (I haven't seen any failures that you might expect every 42 minutes, but I haven't really been keeping a eye on it too closely).

Only one of my 4 accts gets checked ...with proper result; the other three are just gray, no icon.
If I remove the other three accounts, the one left also works.... but not all the time.

virtuado's picture

Currently i do this...
In the xnotifier app i click on 1(greyed or red), and when the login is finalized, i leave the accountpage open until the blue icon  appears, usually after a mail check cycle...or some.
Sometimes the login has some hickups by changing accounts and/or denying access, but eventually you end up in 1.

After the 1st icon appears,  i click on another 1, and repeat the process until my icons are all visible.

A little more time timeconsuming, but eventually you"ll get there.

Changing mailcycle times, like advised above will not help, because when you open your browser all accounts check at once, so at that point it's still the same. Maybe after the 1st check this could calm down microsofts suspicious traffic flagging system a bit, but eventhen the icons do not appear automaticcaly like they should.

You are correct in your statement that the first time it checks, it will check at the same time (and fail), but the next 6 times it checks it works fine.  Like I said, if you have two hotmail accounts and use 6 minutes for one and 7 for the other then the check will fail every 42 minutes (but will work for the other checks).  So there is one check out of 7 and one check out of 6 that will fail for each account, but all the other checks work fine (at least for me).  Of course if you have more than 2 hotmail accounts, the conflict/failure rate will be higher, but it should still work even though you are checking less often.

This is just a workaround for now, hopefully some small delay can be added for email checks to hotmail, then you can go back to having it check all accounts at the same interval (with +x seconds between each check).

The checking of hotmail / outlook accounts returned to normal yesterday & the plugin is working as expected.  Looks like Microsoft fixed whatever they had going on.

CFBancroft's picture

Thanks for bring it up.

Also, it works on old Firefox.