XN 4.2.11 not checking default Gmail account

I have XN 4.2.11 in Firefox 65.0.2 checking 8 Gmail accounts. A few weeks ago, Suddenly it stopped checking my default account, yet it still checks the other 7 just fine.
Then there was the update to XN 4.2.11 and I was hoping that would fix it, but it only changed it from being red all the time to it's normal colour; as if it's being checked, but it still usually doesn't show any new mail, or sometimes it'll show 1, even though there can be dozens of new messages in my inbox.

I have tried completely removing the account from XN, and re-adding it, but nothing changed.
I changed which account is set as default, and now ALL Gmail accounts are RED.
I'm at a loss at what to try next...
Any advice?
TIA

I made a new Firefox profile but not working again and Gmail . Hotmail, Outlook emails are all in red color . I've deleted cookies, history, cache,  If anyone has any advice it would be highly appreciated  but the same thing is happening in Firefox and Chrome Browsers . Thank You , CyberToothTiger

Update: Now it's not just my default account, it's several of them.
Sometimes it will tell me there's 1 new message, but when I log into that account, I find there's actually several new messages. As an example, I just turned on Firefox and XN checked each account; none showing any new messages. But I click on hte first one and I have 8 new messages... I click on the 2nd one and I have 3 new messages... etc., etc.
So at this point, I have to go through each account a few times a day just to see if there is any new messages, as I can't count in XN to tell me if there is any or not. :(

Yes i agree it is affecting more than just one account but several .