Hotmail Script serving X-notifier 3.x for Firefox

You can download it here: Hotmail Script
(Left click and download using the button that will appear at top-right next to the Share button)

Just add it as external script. It will automatically replace the included script with the same name.
(Reloaded users can do the same, in case the included script didn't reach the Reloaded release yet)

Melih's picture

Thank you Jeroen!

FormatC's picture

Hello,

I'm trying to download, but I've get the code, where should I replace that code?

Thanks

 

OK.

 

I got it after some search:

Components\scripts\hotmail.js

jeroen's picture

And renamed it to hotmail. (Using the hotmail+beta name was not such a good idea)
After reverting to the hotmail script, you can delete the hotmail+beta script.

Download and update from this thread's top post:  permalink

CFBancroft's picture

I am Mac user... with Firefox ESR and XN 3.5.25

When I load your hotmail.js, and it disappears all Hotmail host!

Let me know what I can help you in private email.

Thanks, CFBancroft

EDITED:

For Macintosh User:

Can not use (Left click and download from Dropbox)

You need to just click on Hotmail Script and copy from website
and paste into TextWrangler and save and type exactly hotmail.js

I got Bad Request... when I click "Sub-folder"...
but I click normal Hotmail host... no problem.

I did send screenshot to jeroen in private email...
He will review and let me know. Thanks.

jeroen's picture

1. Do you wait long enough to see the Download button appear next to the blue Share button in the right corner of the dropbox page? Screenshot

2. Send me the hotmail.js file you created by copy/paste (as an attachment of your mail, not as copy/paste text in your mail). Change the extension from .js to .txt before you do so to prevent safety measure of gmail. (hotmail.txt)

jeroen's picture

CFB: "When I load your hotmail.js, and it disappears all Hotmail host!"
That must be caused by using the dropbox html instead of the correctly downloaded script. When you don't see the date in the popup for adding scripts that means your script contains syntax error(s).

By back-engineering the hotmail (and yahoo) script from vs 4, I lost the functionality from vs 3 XN sidebar / window. I will correct it when I find the time.

jeroen's picture

Redownload and add to replace the hotmail script.

CFBancroft's picture

It solved.

This script stopped working for me yesterday.  Anyone else having an issue with this script and Hotmail (both the beta and non- beta)?

 

RpD's picture

As of today, it's working on my three hotmail/outlook.com/live.com accounts... two beta, one not.

Looks like the script I was using was called "hotmail+beta" (not sure if this was the same script as the one in this thread).  Anyway, I downloaded the current one in this thread and changed my accounts to use it and it appears to be working now...

Thanks for the reply!

 

Didn't see that info, I guess I was distracted.  Since the old script just stopped working a couple days ago for me, I guess I didn't think any info a month old would be pertanent.

Anyway, thanks for keeping this script updated.  I still haven't moved to Firefox 57 due to so many addons not being compatible yet.  Also, when I checked out X-Notifier 4.x when if first came out, I didnt like it, not sure if it has gotten any better since then.

 

Thanks for the script update! X-Notifier is one of my favorite FF extensions and I was missing it since Palemoon and FF differences deepened (making new versions not compatible) and mail provider changed the login process which breake most scripts...

... though I think I found it too late since it's not working for me (on Palemoon 27.7).

Anyone can confirm the script is broken?

Best regards

 

PS: Anyone has a working Office 365 script (the 2015 one is broken)? I have 2 professional email accounts there

Just installed the new version(3.5.26) but Outlook is still not working...

jeroen's picture

The beta interface got changed and therefore didn't get recognized by the script.

Download and update from this thread's top post:  permalink

thank you so much

jeroen's picture

You're very welcome ;-)

jeroen's picture

Download and update from this thread's top post:  permalink

Hotmail/outlook not working again even with updated script :(

jeroen's picture

Just me again that Hotmail/Outlook isn't working for? Tried clean profile, etc still not working

RpD's picture

Hi... Jeroen and I have been having trouble with CAPTCHA preventing us from posting/replying.
He says  you: "should reload the hotmail script from my dropbox in case he uses 2-step verification 
(I applied the last 2nd fix for 2-step verification of Byungwook).
http://xnotifier.tobwithu.com/dp/comment/13373#comment-13373"

 

jeroen's picture

@ScootyPuffJr:
When you use 2-step verification, reload the script at this thread's top post:
http://xnotifier.tobwithu.com/dp/node/3624

RpD's picture

You're welcome. Let's see if this posts.

Thank you.

Will X-notifier reloaded be updated with this (or can i just put the script in the xpi using a zip archiver)?

Best regards

jeroen's picture

Just add it as external script. It will automatically replace the included script with the same name.
(Reloaded users can do the same, in case the included script didn't reach the Reloaded release yet)

jeroen's picture

Download and update from this thread's top post:  permalink

Jamiel's picture

which mozilla i need to download to get X-notifier-version 3.5.23 because it stop working on my   Mozilla: 49.0 (x86 en-US)

RpD's picture

Please don't post multiple times with the same question... it's called spamming the forum.
I answered your other post in topic "Version 4.2.13 issue".

Offsprung's picture

This is turning into quite a clusterF! Update takes you to the no more google in ffx update.
App is no longer a real app so no import scripts. So now I guess find the folder in ffx folder and rename it to the old script name?

RpD's picture

Mozilla/firefox changed the application programming interface, XN had to change... the new 4.x app for firefox still supports only embedded scripts for major email providers. The 4.x app for Chrome still supports loading custom scripts for other providers.  

- Jeroen kindly ports scipts from 4.x to old 3.x version of X-Notifier for Old firefox, but he's on vacation right now.

You could use two browsers... current firefox (perhaps with XN 4 for firefox, or not), and current Chrome with XN 4 (for Chrome) for all scripts.  Or just use Chrome.
Then you'd just have to put up with clusterfuck of email providers constantly changing logins.

I lost three secondary providers because they changed login too much for XN to support anymore. Oh well.

 

 

jeroen's picture

Thanks

RpD's picture

;) 

Jamiel's picture

You mean i should install X-notifier 4.2.13 it going to work with Mozilla: 49.0 (x86 en-US)

RpD's picture

Version 4.x of X-Notifier is meant for newer versions of Firefox... like Firefox 57 or 58+.
Firefox 56, I think, and older ...can use XN version 3.x
Old versions are not as secure anymore, probably shouldn't be used. Just my opinion. May be time to let go the past, or use CHROME, which can still load custom scripts even with version 4.x of XN.