Adding mail.ru and inbox.ru to x-notifier

in previous versions, I would add scripts for these services.

Now I do not see where I can add additional services.

How to solve this problem?

fomenkoandrey's picture

>>> Go to Safari (allowed options to add scripts!)

where is that?

i dont foind nothing like that in the FF extention options.

http://image.prntscr.com/image/ea9094eadf8a40b6978dabb0760616f1.png

CFBancroft's picture
fomenkoandrey's picture

as you can see on the screenshot - there is no such button.

http://image.prntscr.com/image/a1ff9ee9aaed421ab3323cec0904fb4b.png

yesterday the extension worked perfectly. today after the update - all data is reset and there is no way to add the necessary scripts of the mail systems.

i use latest firefox 50.0.2 on windows 10

RpD's picture

Mozilla (Firefox) is forcing a big rewrite onto all the add-on developers by changing its API or Application Programming Interface for Firefox 50+.  If you had the Firefox global "automatic updates" for addons turned on... and upgraded to FF 50+ ... you probably got X-Notifier auto-updated, but accounts could not be carried over (see below). (Each add-on's "More" page in the Add-ons list has its own update settings, which default to "default" ...the Firefox global setting.)

- So... eventually we users who upgrade Firefox to version 50+ will have to transition to XN version 4.x. Unfortunately, the API changes mean dropping support for POP3/IMAP and custom scripts, among other things. However... you can, if you want, for the time being, continue to use version 3.5.23 on FF 50+ untill Mozilla locks down the new changes for addons.

Others have downgraded to 3.5.23, and... recovered their account definitions... 
You can try reinstalling X-Notifier 3.5.23 ...it can be downloaded here:  https://addons.mozilla.org/en-US/firefox/addon/xnotifier/versions
...and, after reinstalling, you should then turn off automatic updates (just for X-Notifier) by going to FF Tools, Addons, find X-Notifier, click 'More', scroll down to 'Automatic Updates' and select 'Off'... so that it doesn't auto-update to 4.02 right away.  Later you may want to set that setting back to "Default" for automatic updates... which won't have this API changing problem (for a long while anyway).
- THEN, in 3.5.23, be sure to Export (backup) your account definitions by going to X-Notifier 'Options', scroll down and click 'Export'.
After doing that... if you want, you can update back to 4.02... (as it's necessary to Import your accounts, or else redefine them from scratch, as they are not autmatically transferred during the update from 3.5.23 to 4.05 ...because data structures have changed)... but, again, there are -no- custom scripts in 4.x.
- NOTE:  After 'Add'ing accounts in XN 4.02 ...be sure to (scroll down, if necessary, and) click "Save"  ...or they won't be.

XN 4.02 supports hotmail/outlook/live.com accounts, gmails, yahoo, and AOL... and RSS (my imported RSS definitions work for me anyway).  

Or... you can switch to X-Notifier Neo for Firefox... or... switch to Chrome and X-Notifier for Chrome (custom scripts supported, but no POP3/IMAP) ...or... Safari, on a Mac (no longer available for Windows).

Just FYI, you can download the older 49.0.2 version of Firefox; 
https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

fomenkoandrey's picture

>>> hotmail/outlook/live.com accounts,  yahoo, and AOL.
I do not know any person who use these services.
only gmails, mail.ru, inbox.ru, yandex

>>> Chrome
This browser is not as good as firefox, i dont use it

>>> Safari
This browser is as bad as Internet Explorer.

thank You!!!
i installed X-Notifier 3.5.23 - works perfectly!

will XN 4.x support custom scripts? maybe most popular mail systems like  mail.ru !/ inbox.ru, yandex will be included by default?

 

RpD's picture

The developer of X-Notifier 4.x has said he cannot program for custom scripts due to limitations imposed by the new Mozilla/Firefox API (application programming interface).  If Mozilla/Firefox doesn't make it possible, X-Notifier can't do it.

I expect he will only 'embed' (include within the program itself) access to webmail that he can program for, that are most popular globally... but I have no idea what he can include by default.
Maybe Mozilla/Firefox will change in the future.  

Chrome and Safari, maybe Opera, can still do custom scripts.

I use all the browsers, somewhat (except Safari is not updated anymore for Windows)... and I use those email 'services', among several others.

CFBancroft's picture

SeaMonkey and Thunderbird...

BOTH are email client!

it will NEVER remove POP3/IMAP program and continue do custom scripts!

I hope that Tobwithu will continue support 3.5.23 & LATER ... go along with POP3/IMAP!

RpD's picture

I would think SeaMonkey/Thunderbird will need continued support of 3.x version, if there's to be any new X-Notifier for them... otherwise, they may be frozen on 3.5.23.

SeaMonkey includes the Internet browser/Composer as its main function, I think... but it does do email.
Thunderbird is email with the Lightning calendar!